您的位置:首页 > 其它

POJ 3311 Hie with the Pie (状压DP)

2014-08-15 10:06 567 查看


Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before
he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you
to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integern indicating the number of orders to deliver, where 1 ≤
n ≤ 10. After this will ben + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and then locations (numbers 1 to
n). The jth value on the ith line indicates the time to go directly from location
i to locationj without visiting any other locations along the way. Note that there may be quicker ways to go fromi to
j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from locationi to
j may not be the same as the time to go directly from locationj to
i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0


Sample Output

8

思路:类TSP问题,注意每一个点可以走多次,所以先用Floyd处理出两点之间的最短距离,接下来就是TSP了

#include <iomanip>
#include <cstdio>
#include <map>
#include <queue>
#include <cstring>
#include <iostream>
#include <vector>
#include <cmath>
#include <string>
using namespace std;
#define LL long long
const int mod =1e8;
#define inf 0x3f3f3f3f
#define INF (1<<20)
#define lson id<<1,l,mid
#define rson id<<1|1,mid+1,r
int dis[12][12],dp[1<<12][12],cost[1<<12];
int n;
/*dp(i,s)=min{dp(j,s-{j})+dis(i,j)|j属于s}*/
int main()
{
while(scanf("%d",&n)&&n)
{
for(int i=0;i<=n;i++)
{
for(int j=0;j<=n;j++)
{
scanf("%d",&dis[i][j]);
}
}
for(int k=0;k<=n;k++)
{
for(int i=0;i<=n;i++)
{
for(int j=0;j<=n;j++)
{
dis[i][j]=min(dis[i][k]+dis[k][j],dis[i][j]);
}
}
}
for(int s=0;s<(1<<n);s++)
{
for(int i=1;i<=n;i++)
{
if(s&(1<<(i-1)))
{
if(s==(1<<(i-1))) dp[s][i]=dis[0][i];//dp 边界条件
else
{
dp[s][i]=INF;
for(int j=1;j<=n;j++)
{
if((s&(1<<(j-1)))&&(j!=i))
{
dp[s][i]=min(dp[s][i],dp[s^(1<<(i-1))][j]+dis[j][i]);
}
}
}
}
}
}
int ans=dp[(1<<n)-1][1]+dis[1][0];
for(int i=2;i<=n;i++)
{
ans=min(ans,dp[(1<<(n))-1][i]+dis[i][0]);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  状态压缩DP POJ3311