您的位置:首页 > 其它

hdu-oj 1570 AC

2014-08-15 10:00 274 查看

A C

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3773    Accepted Submission(s): 2412


[align=left]Problem Description[/align]
Are you excited when you see the title "AC" ? If the answer is YES , AC it ;

You must learn these two combination formulas in the school . If you have forgotten it , see the picture.



Now I will give you n and m , and your task is to calculate the answer .
 Input
In the first line , there is a integer T indicates the number of test cases.

Then T cases follows in the T lines.

Each case contains a character 'A' or 'C', two integers represent n and m. (1<=n,m<=10)
 Output
For each case , if the character is 'A' , calculate A(m,n),and if the character is 'C' , calculate C(m,n).

And print the answer in a single line.
 Sample Input

2
A 10 10
C 4 2

 Sample Output

3628800
6求阶乘附代码:
#include <stdio.h>
int main()
{   int t,n,m,i,j;
char ch;
scanf("%d",&t);
getchar();
while(t--){
scanf("%c%d%d",&ch,&n,&m);
int sum=1;
for(int i=n;i>n-m;i--)
{
sum=sum*i;
}
if(ch=='A') printf("%d\n",sum);
if(ch=='C')
{
int num=1;
for(int j=m;j>0;j--)
{
num=num*j;
}
printf("%d\n",sum/num);
}
getchar();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: