您的位置:首页 > 其它

【二分匹配】HDU1068-Girls and Boys

2014-08-14 21:15 363 查看
说说什么是最大独立集

在二分图中,

独立集指的是两两之间没有边的顶点的集合,

顶点最多的独立集成为最大独立集。

二分图的最大独立集=节点数-最大匹配数

例子:

1

2 - 1'

3 - 2'

4 - 3'   

    4'

最大独立集=8-3=5.

最大独立集是1,2,3,4,4'

 

例题:

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7486    Accepted Submission(s): 3419

Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying
the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students

the description of each student, in the following format

student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...

or

student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.

For each given data set, the program should write to standard output a line containing the result.

 

Sample Input

7

0: (3) 4 5 6

1: (2) 4 6

2: (0)

3: (0)

4: (2) 0 1

5: (1) 0

6: (2) 0 1

3

0: (2) 1 2

1: (1) 0

2: (1) 0

 

Sample Output

5

2

 

Source

Southeastern Europe 2000

 

 

 

 

依旧是二分匹配,用匈牙利算法。。。。

等等,好像没有所谓的集合A和集合B了,好像所有人都在相互喜欢= =

就是说0 喜欢 4 5 6,4 5 6也喜欢 0。。。。也就是说这里的数字是

不分男女的。。。仅仅是数字喜欢数字(暂且这么看吧)

这就有影响了,假设0选择了4做匹配,那么4只能选0做匹配了。。。。

这就把原来的二分图匹配变成了“一分图”匹配。。。(自己起得名= =)

这样,按原来匈牙利的做法,求出来是男数字与女数字之间的匹配,

所以只要将匹配的结果除以2,就是所谓的“一分图”匹配数量,

就可以用刚刚的公式:二分图的最大独立集=节点数-最大匹配数

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int line[1100][1100],used[1100],boy[1100];
int n;//全局变量和局部变量不要使用相同名称的变量,否则导致结果出错
int Find(int x)
{
int i;
for(i=0;i<n;i++)
{
if(line[x][i]==1&&used[i]==0)
{
used[i]=1;
if(boy[i]==0||Find(boy[i]))
{
boy[i]=x;
return 1;
}
}
}
return 0;
}
int main()
{
int i,j,x,y,z,sum;
while(scanf("%d",&n)!=EOF)
{
memset(line,0,sizeof(line));
memset(boy,0,sizeof(boy));
for(i=0;i<n;i++)
{
scanf("%d: (%d)",&x,&y);
while(y--)
{
scanf("%d",&z);
line[x][z]=1;//x跟z暧昧
line[z][x]=1;
}
}
/*for(i=0;i<n;i++)//检测一下谁和谁暧昧.....
{
for(j=0;j<n;j++)
if(line[i][j]==1)
printf("%d LOVE %d\n",i,j);
}*/
sum=0;
for(i=0;i<n;i++)
{
memset(used,0,sizeof(used));
if(Find(i)) sum++;//找到可以结合的就记录
}
//因为此题是单集合的,所以不能够按照平常的求最大独立集
//的方法,要除以2(因为实际上是一分图而不是二分图....)
printf("%d\n",n-sum/2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: