您的位置:首页 > 产品设计 > UI/UE

Ultra-QuickSort(poj 2299归并排序)

2014-08-14 16:55 288 查看
http://acm.sdut.edu.cn:8080/vjudge/contest/view.action?cid=232#problem/A

B - Ultra-QuickSort
Time Limit:7000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit Status

Description


In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,
Ultra-QuickSort produces the output
0 1 4 5 9 .
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0


Sample Output

6
0

题目大意:

给出长度为n的序列,每次只能交换相邻的两个元素,问至少要交换几次才使得该序列为递增序列。

解题思路:

一看就是冒泡,交换一次记录一次就可以了

但是n的范围达到50W,冒泡O(n^2)的复杂度铁定超时(即使有7000ms,其实这是一个陷阱)

直接用快排又不符合题目的要求(相邻元素交换),快排是建立在二分的基础上的,操作次数肯定比在所要求的规则下的交换次数要更少

那么该怎么处理?

其实这题题目已经给出提示了:Ultra-QuickSort

特殊的快排,能和快排Quicksort相媲美的就是归并排序Mergesort了,O(nlogn)

但是用归并排序并不是为了求交换次数,而是为了求序列的逆序数(学过《线代》的同学应该很熟悉了)

一个乱序序列的 逆序数 = 在只允许相邻两个元素交换的条件下,得到有序序列的交换次数

例如例子的

9 1 0 5 4

由于要把它排列为上升序列,上升序列的有序就是 后面的元素比前面的元素大

而对于序列9 1 0 5 4

9后面却有4个比9小的元素,因此9的逆序数为4

1后面只有1个比1小的元素0,因此1的逆序数为1

0后面不存在比他小的元素,因此0的逆序数为0

5后面存在1个比他小的元素4, 因此5的逆序数为1

4是序列的最后元素,逆序数为0

因此序列9 1 0 5 4的逆序数 t=4+1+0+1+0 = 6 ,恰恰就是冒泡的交换次数

PS:注意保存逆序数的变量t,必须要用龙long long定义,intlong都是无法保存的。。。。会导致WA

注意__int64类型的输出必须使用指定的c格式输出,printf(“%I64d”,t);

cout是无法输出__int64类型的

序列数组s[]int就足够了,每个元素都是小于10E而已

归并排序利用了二分的思想:

划分问题:把序列分成元素个数尽量相等的两半。

递归求解:把两半元素分别排序。

合并问题:把两个有序表合并成一个。

例如输入 1 2 3 4 5 6 7 8

首先分成1 2 3 4||5 6 7 8

之后1 2 |3 4||5 6 7 8

1 2 3 4||5 6 |7 8

1 2 3 4||5 6 7 8

1 2 3 4 5 6 7 8

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<iostream>
using namespace std;
int a[500001],n;
long long sum;
void merge(int a[],int l,int mid,int r)
{
int t[500001];
int i,j,p;
for(i=l,j=mid+1,p=0;i<=mid&&j<=r;p++)
{
if(a[i]<=a[j]) t[p]=a[i++];
else
{
t[p]=a[j++];
sum=sum+(mid-i+1);
}
}
while(i<=mid) t[p++]=a[i++];
while(j<=r) t[p++]=a[j++];
for(int i=l,p=0;i<=r;i++)
a[i]=t[p++];
}
void mergesort(int a[],int l,int r)
{
if(l==r) a[l]=a[r];
else
{
int mid=l+(r-l)/2;//如果写成mid=(l+r)/2;自我感觉(l+r)会超范围
mergesort(a,l,mid);
mergesort(a,mid+1,r);
merge(a,l,mid,r);
}
}
int main()
{
while(scanf("%d",&n)!=EOF&&n!=0)
{
sum=0;
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
mergesort(a,0,n-1);
printf("%lld\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: