您的位置:首页 > 其它

hdu 2069 Coin Change

2014-08-14 16:26 232 查看
[align=left]Problem Description[/align]
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents
with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.

[align=left]Input[/align]
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.

[align=left]Output[/align]
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

[align=left]Sample Input[/align]

11
26


[align=left]Sample Output[/align]

4
13暴力解法[code]#include<stdio.h>
int main()
{
int i,j,k,l;
int n,t;
while (scanf("%d",&n)!=EOF)
{
t=0;
for (int i=0;i*50<=n;i++)
for (int j=0;j*25<=n;j++)
for (int k=0;k*10<=n;k++)
for (int l=0;l*5<=n;l++)
if (n-i*50-j*25-k*10-l*5>=0&&i+j+k+l+n-i*50-j*25-k*10-l*5<=100)
t++;
printf("%d\n",t);
}
}

动态规划还需理解#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int n,dp[110][300]; // dp[j][k] 统计到第i个coins k钱 dived to j 部分 的分法数
int money[5]={1,5,10,25,50};
int main()
{
int i,j,k;
while(~scanf("%d",&n))
{
memset(dp,0,sizeof(dp));
dp[0][0]=1;
for(i=0;i<5;i++)
for(j=1;j<=100;j++)
for(k=n;k>=money[i];k--) //这样写应该使对的,可写成这样for(int k=money[i];k<=n;k++) 也没WA,估计数据弱了
dp[j][k]+=dp[j-1][k-money[i]];
int ans=0;
for(int i=0;i<=100;i++) //从0开始,注意 dp[0][0]
ans+=dp[i]
;
printf("%d\n",ans);
}
return 0;
}
[/code]简洁版
#include <cstdio>
const int MAXN = 8000;
int n, coin[5] = {1, 5, 10, 25, 50};
__int64 dp[MAXN] = {1};

int main() {
for (int i = 0; i < 5; i++)
for (int j = 0; j < MAXN - 100; j++)
dp[j + coin[i]] += dp[j];
while (scanf("%d", &n) != EOF)
printf("%I64d\n", dp
);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: