您的位置:首页 > 大数据 > 人工智能

hdu 2473 Junk-Mail Filter 并查集 虚父节点

2014-08-14 11:11 441 查看


点击打开链接题目链接


Junk-Mail Filter

Time Limit: 15000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5957 Accepted Submission(s): 1895



Problem Description

Recognizing junk mails is a tough task. The method used here consists of two steps:

1) Extract the common characteristics from the incoming email.

2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so

relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.

Please help us keep track of any necessary information to solve our problem.



Input

There are multiple test cases in the input file.

Each test case starts with two integers, N and M (1 ≤ N ≤ 105 , 1 ≤ M ≤ 106), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.

Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.



Output

For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.



Sample Input

5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0Sample Output
Case #1: 3
Case #2: 2



m代表 a和b是一棵树内的
s代表删除
需要建立虚父节点
感觉这东西只能意会啊- -想讲讲不清楚。。
语文太差。。还是画图吧



#include<cstdio>
#include<cstring>
int father[1100010];
int majia[100010];
int n,m;
int cnt;
void init()
{
    for(int i=0;i<n;i++)
    {
        father[i]=i;
        majia[i]=i;
    }
    cnt=n;
}
int find(int x)
{
    if(x!=father[x])
        father[x]=find(father[x]);
    return father[x];
}
void add(int a,int b)
{
    int x=find(a);
    int y=find(b);
    if(x!=y)
    {
        father[x]=y;
    }
}
void del(int a)
{
    majia[a]=cnt;
    father[majia[a]]=cnt++;
}
bool flag[1100010];
int main()
{
    int i;
    char str[5];
    int a,b;
    int cas=0;
    while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
    {
        init();
        cas++;
        while(m--)
        {
            scanf("%s",str);
            if(str[0]=='M')
            {
                scanf("%d %d",&a,&b);
                add(majia[a],majia[b]);
            }
            else
            {
                scanf("%d",&a);
                del(a);
            }
        }
        int ans=0;
        memset(flag,0,sizeof(flag));
        for(i=0;i<n;i++)
        {
            int x=find(majia[i]);
            if(flag[x]==0)
            {
                ans++;
                flag[x]=1;
            }
        }
        printf("Case #%d: %d\n",cas,ans);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: