您的位置:首页 > 其它

dfs_poj_2531

2014-08-14 09:28 417 查看
题目链接:http://poj.org/problem?id=2531

Network Saboteur

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9246 Accepted: 4345
Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 

A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 

Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 

The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).
Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 

Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.
Sample Input
3
0 50 30
50 0 40
30 40 0

Sample Output
90

基础的搜索题,用搜索穷举出各种状态,取最大值即可,搜索时基础,不难,计算最大值的时候,脑子抽了, 居然错了好几次
代码:

#include <stdio.h>
#include <string.h>

int map[22][22], n, Max;
short mark[22]; ///标记数组

void visit(int pos, int sum)
{
int i;
for( i = 1; i <= n; i++)
{
if(mark[i]){ sum -= map[pos][i]; } ///删除重复部分
else { sum += map[pos][i]; } ///添加
}
if(Max < sum)Max = sum;
for( i = pos + 1; i <= n; i++)
{
mark[i] = 1;
visit(i, sum);
mark[i] = 0;
}
}

int main()
{
int i, j;
while(~scanf("%d",&n))
{
Max = 0;
memset(map,0,sizeof(map));
memset(mark,0,sizeof(mark));
for( i = 1; i <= n; i++)
{
for( j = 1; j <= n; j++)
{
scanf("%d",&map[i][j]);
}
}
for( i = 1; i <= n; i++)
{
mark[i] = 1;
visit(i, 0); ///dfs 函数 写visit 写习惯了
mark[i] = 0;
}
printf("%d\n",Max);
}
return 0;
}
运行结果:

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dfs 搜索 图论