您的位置:首页 > 其它

HDU-2258-Continuous Same Game (1)(DFS+模拟)

2014-08-13 21:15 302 查看
[align=left]Problem Description[/align]
Continuous Same Game is a simple game played on a grid of colored blocks. Groups of two or more connected (orthogonally, not diagonally) blocks that are the same color may be removed from the board. When a group of blocks is removed,
the blocks above those removed ones fall down into the empty space. When an entire column of blocks is removed, all the columns to the right of that column shift to the left to fill the empty columns. Points are scored whenever a group of blocks is removed.
The number of points per block increases as the group becomes bigger. When N blocks are removed, N*(N-1) points are scored.

LL was interested in this game at one time, but he found it is so difficult to find the optimal scheme. So he always play the game with a greedy strategy: choose the largest group to remove and if there are more than one largest group with equal number of blocks,
choose the one which contains the most preceding block ( (x1,y1) is in front of (x2,y2) if and only if (x1<x2 || x1==x2 && y1<y2) ). Now, he want to know how many points he will get. Can you help him?
 

[align=left]Input[/align]
Each test case begins with two integers n,m ( 5<=n,m<=20 ), which is the size of the board. Then n lines follow, each contains m characters, indicating the color of the block. There are 5 colors, and each with equal probability.
 

[align=left]Output[/align]
For each test case, output a single line containing the total point he will get with the greedy strategy.

 

[align=left]Sample Input[/align]

5 5
35552
31154
33222
21134
12314

 

[align=left]Sample Output[/align]

32

Hint
35552 00552 00002 00002 00000 00000
31154 05154 05104 00004 00002 00000
33222 01222 01222 00122 00104 00100
21134 21134 21134 25234 25234 25230
12314 12314 12314 12314 12314 12312

The total point is 12+6+6+2+6=32.

思路:DFS找最大的联通块消去。注意向左移动的时候连续两列都为空的情况。

#include <stdio.h>

int n,m,total,nxt[4][2]={{0,-1},{-1,0},{1,0},{0,1}};
bool vis[20][20];
char d[20][21];

void dfs(int x,int y,int num)
{
for(int i=0;i<4;i++)
{
x+=nxt[i][0];
y+=nxt[i][1];

if(x>=0 && x<n && y>=0 && y<m && !vis[x][y] && d[x][y]==num)
{
vis[x][y]=1;

total++;

dfs(x,y,num);
}

x-=nxt[i][0];
y-=nxt[i][1];
}
}

void tran(int x,int y,int num)
{
for(int i=0;i<4;i++)
{
x+=nxt[i][0];
y+=nxt[i][1];

if(x>=0 && x<n && y>=0 && y<m && d[x][y]==num)
{
d[x][y]='0';

tran(x,y,num);
}

x-=nxt[i][0];
y-=nxt[i][1];
}
}

int main()
{
int i,j,k,mx,x,y,ans,remain,t;

while(~scanf("%d%d",&n,&m))
{
for(i=0;i<n;i++) scanf("%s",d[i]);

ans=0;

remain=n*m;

while(remain)
{
mx=0;

for(i=0;i<n;i++) for(j=0;j<m;j++) vis[i][j]=0;

for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
if(d[i][j]>'0' && !vis[i][j])
{
vis[i][j]=1;

total=1;

dfs(i,j,d[i][j]);

if(total>mx)
{
mx=total;

x=i;
y=j;
}
}
}
}

remain-=mx;

ans+=mx*(mx-1);

tran(x,y,d[x][y]);

d[x][y]='0';

for(i=n-1;i>=0;i--)//向下移动
{
for(j=0;j<m;j++)
{
if(d[i][j]=='0')
{
for(k=i-1;k>=0;k--)
{
if(d[k][j]>'0')
{
d[i][j]=d[k][j];
d[k][j]='0';

break;
}
}
}
}
}

t=m-1;
while(t--)//向左移动,注意连续两列都为空的情况
{
for(j=0;j<m-1;j++)
{
for(i=0;i<n;i++) if(d[i][j]>'0') break;

if(i==n)
{
for(i=0;i<n;i++)
{
d[i][j]=d[i][j+1];

d[i][j+1]='0';
}
}
}
}
}

printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: