您的位置:首页 > 其它

HDU 1597 find the nth digit 找规律

2014-08-13 14:15 295 查看
find the nth digit

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8347 Accepted Submission(s): 2380


Problem Description
假设:

S1 = 1

S2 = 12

S3 = 123

S4 = 1234

.........

S9 = 123456789

S10 = 1234567891

S11 = 12345678912

............

S18 = 123456789123456789

..................

现在我们把所有的串连接起来

S = 1121231234.......123456789123456789112345678912.........

那么你能告诉我在S串中的第N个数字是多少吗?
Input
输入首先是一个数字K,代表有K次询问。

接下来的K行每行有一个整数N(1 <= N < 2^31)。
Output
对于每个N,输出S中第N个对应的数字.
Sample Input
6
1
2
3
4
5
10


Sample Output
1
1
2
1
2
4


/*
hdoj 找规律 
(1+x)x/2=N 
x=sqrt((double) 2*n+0.25)-0.5
*/

#include<iostream>
#include<stdio.h>
#include<cmath>
using namespace std;

int main(){
    
    int n;
    __int64 N,x,y; 
    scanf("%d",&n);
    while(n--)
    {
        scanf("%I64d",&N);
        x=(__int64)(sqrt((double) 2*N+0.25)-0.5);
        if(N==x*(x+1)/2) x--;
        y=x*(x+1)/2;
        printf("%d\n",(N-y)%9==0?9:(N-y)%9);
    }
    return 0;
}


/*
hdoj 找规律  方法二 
*/

#include<iostream>
#include<stdio.h>
#include<cmath>
using namespace std;

int main(){
    
    int n,N,k; 
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&N);
        int a=1;
        while(N>a)
        {
            N-=a;
            a++;
        }
        printf("%d\n",N%9==0?9:N%9);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: