您的位置:首页 > 其它

hdu 1018 计算一个数阶乘的位数

2014-08-12 17:00 447 查看
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of
digits in the factorial of the number.
[align=left]Input[/align]
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
[align=left]Output[/align]
The output contains the number of digits in the factorial of the integers appearing in the input.
[align=left]Sample Input[/align]

2
10
20

[align=left]Sample Output[/align]

7
19

题意:求一个数的阶乘的位数

因为根据数学知识可以知道:

log10(1*2*3*4.........*n)=log10(1)+log10(2)+log10(3)+log10(4)...........+log10(n);

又因为阶乘很可能超出整形,不容易计算,所以就应用log进行计数

#include<stdio.h>

#include<math.h>

int main()

{

    int t,m;

    scanf("%d",&t);

    while(t--)

    {

        double sum=0;

        scanf("%d",&m);

        for(int i=1;i<=m;i++)

         sum+=log10(i);

         printf("%d\n",((int)sum)+1);    

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: