您的位置:首页 > 其它

poj 3096(map的应用)

2014-08-11 22:52 309 查看
Surprising Strings

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5894Accepted: 3861
Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible
distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG
is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input
ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output
ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

Source
Mid-Central USA 2006
直接用map就解决了,只有两个字符hash也很简单的。
AC代码:
#include<iostream>
#include<map>
#include<algorithm>
#include<string>
#include<string.h>
using namespace std;
map <string , int> m[100];
char s[90];
int judge(){
int len=strlen(s);
for(int i=1;i<len-1;i++){
m[i].clear();
for(int j=0;i+j<len;j++){
char ch[3];
string str;
ch[0]=s[j]; ch[1]=s[i+j]; ch[2]='\0';
str=ch;
if(m[i][str])
return 0;
else
m[i][str]=1;
}
}
return 1;
}
int main(){
while(cin>>s && s[0]!='*'){
if(judge())
cout<<s<<" is surprising."<<endl;
else
cout<<s<<" is NOT surprising."<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: