您的位置:首页 > 其它

HDU1513(LCS+滚动数组)

2014-08-11 22:14 183 查看
Problem Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order
to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters
from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

 

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

 

Sample Input

5
Ab3bd

 

Sample Output

2

 

经典dp题了吧
将该字符串与其反转求一次LCS,然后所求就是n减去最长公共子串的长度,
但是要注意这里字符串最长有5000,dp数组二维都开5000的话就会超内存,这里就用到了滚动数组,
因为在LCS的计算中,使用到的上一次保留下来的结果就只有两行(i行和i-1行),所以只需要将新的结果覆写掉最旧的结果就行
比如,我们不用滚动数组时,会根据第i-1行和第i行的结果计算并存放在第i+1行中
但在滚动数组中,我们也会根据第i-1行和第i行的结果计算,但最新的结果就会存放在第i-1行中,因为已经用过了,没用了不会对后面的结果才生影响
再就是周期为2,则i%2就实现了

#include<stdio.h>
#include<string>
#include<algorithm>
using namespace std;
char s1[5005],s2[5005];
int dp[2][5005];

void LCS(int len1,int len2)
{
memset(dp,0,sizeof(dp));
for(int i=1;i<=len1;i++)
for(int j=1;j<=len2;j++)
if(s1[i-1]==s2[j-1])
dp[i%2][j]=dp[(i-1)%2][j-1]+1;
else
dp[i%2][j]=max(dp[i%2][j-1],dp[(i-1)%2][j]);
}

int main()
{
int n;
while(~scanf("%d",&n))
{
scanf("%s",s1);
for(int i=0;i<n;i++)
s2[i]=s1[n-i-1];
LCS(n,n);
printf("%d\n",n-dp[n%2]
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: