您的位置:首页 > 其它

POJ 3461 Oulipo (kmp模板)

2014-08-11 20:30 399 查看
Oulipo

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 23379Accepted: 9364
Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program
that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T,
count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output
1
3
0

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
char word[10010],text[1000010];
int next[10010];
int ans;
void kmp()
{
int k=-1,len1=strlen(word),len2=strlen(text);
next[0]=-1;
for(int i=1;i<len1;i++)//计算自身真后缀又是自身最长前缀的字符串长度:比如abccabccabca对应-1,-1,-1,-1,0,1,2,3,4,5,6,0
{
while(k>-1&&word[k+1]!=word[i])//不相等就回到与word[k]相同的下标
k=next[k];
if(word[k+1]==word[i])//相等长度加1
k++;
next[i]=k;//用next数组存不相等时下一次查询的下标
}
for(int i=0,j=-1;i<len2;i++)//扫一遍就能看是否匹配
{
while(j>-1&&word[j+1]!=text[i])
{
j=next[j];
}
if(word[j+1]==text[i])
j++;
if(j==len1-1)
{
ans++;
j=next[j];
}
}
}
int main()
{
int t;
cin>>t;
while(t--)
{
ans=0;
scanf("%s%s",word,text);
kmp();
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: