您的位置:首页 > 其它

HDOJ题目2120 Ice_cream's world I(并查集)

2014-08-11 19:22 405 查看

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 552    Accepted Submission(s): 310


[align=left]Problem Description[/align]
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition
the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

[align=left]Input[/align]
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between
A and B has a wall(A and B are distinct). Terminate by end of file.
 

[align=left]Output[/align]
Output the maximum number of ACMers who will be awarded.

One answer one line.
 

[align=left]Sample Input[/align]

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

 

[align=left]Sample Output[/align]

3

 

[align=left]Author[/align]
Wiskey
 

[align=left]Source[/align]
HDU 2007-10 Programming Contest_WarmUp

 

[align=left]Recommend[/align]
威士忌   |   We have carefully selected several similar problems for you:  2122 2118 2119 2121 2126 
 

并查集的应用,用来查找被分割的区域个数。

即当两个节点值相同时说明已经为了一个圈,否则不可能,此时区域个数加1.

ac代码

#include<stdio.h>
int f[10010];
int find(int x)
{
int i,r,j;
r=x;
while(f[r]!=r)
r=f[r];
i=x;
while(i!=r)
{
j=f[i];
f[i]=r;
i=j;
}
}
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
int i,sum=0;
memset(f,0,sizeof(f));
for(i=1;i<=10010;i++)
f[i]=i;
while(m--)
{
int a,b,fa,fb;
scanf("%d%d",&a,&b);
fa=find(a);
fb=find(b);
if(fa!=fb)
{
f[fa]=fb;
}
else
sum++;
}
printf("%d\n",sum);
}
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: