您的位置:首页 > 其它

poj 2387 Til the Cows Come Home

2014-08-11 16:25 369 查看
Til the Cows Come Home

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 29645 Accepted: 9967
Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various
lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output
90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

思路:最短路径还是单源的 Dijkstra 可以ok 但注意要判断重边并且 重边的话 要最小的权值

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <queue>
#include <set>
#include <vector>
using namespace std;
#define maxn 1005
#define INF 10000000
int point[maxn][maxn];
int d[maxn],flag[maxn];
int n,m;
void Dijkstra(int v1){
int i,j,v,k;
for(i=1;i<=n;i++){
flag[i]=0;
d[i]=point[v1][i];
}
d[v1]=0;
flag[v1]=1;
for(i=2;i<=n;i++){
int temp=INF;
for(j=1;j<=n;j++)
if(!flag[j]&&temp>d[j]){
temp=d[j];
v=j;
}
flag[v]=1;
for(k=1;k<=n;k++)
if(!flag[k]&&point[v][k]<INF&&(temp+point[v][k]<d[k]))
d[k]=temp+point[v][k];
}
}
int main(){
int i,j;
int a,b,c;
while(scanf("%d %d",&m,&n)!=EOF){
for(i=1;i<=n;i++){
for(j=1;j<=n;j++)
point[i][j]=point[j][i]=INF;
}
for(i=0;i<m;i++){
scanf("%d %d %d",&a,&b,&c);
if(point[a][b]<INF)   //判定重边 去最小的权值
c=min(point[a][b],c);
point[a][b]=point[b][a]=c;
}
Dijkstra(1);
cout<<d
<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj dijkstra