您的位置:首页 > 其它

HDOJ 题目1566&题目1544 S-Nim(sg博弈模板)

2014-08-11 15:13 295 查看

S-Nim

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4451    Accepted Submission(s): 1934


[align=left]Problem Description[/align]
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:

  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.

Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:

  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.

It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player's last move the xor-sum will be 0.

  The xor-sum will change after every move.

Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove
a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position.
This means, as expected, that a position with no legal moves is a losing position.
 

[align=left]Input[/align]
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0
< m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by
a 0 on a line of its own.
 

[align=left]Output[/align]
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.

 

[align=left]Sample Input[/align]

2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0

 

[align=left]Sample Output[/align]

LWW
WWL

 

[align=left]Source[/align]
Norgesmesterskapet 2004

 

[align=left]Recommend[/align]
LL   |   We have carefully selected several similar problems for you:  1404 1524 1729 1079 1730 
 

思路:http://blog.csdn.net/hnust_xiehonghao/article/details/9343045

ac代码

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int n,s[10100],sg[11000];//开太大了栈溢出啊
//int v[100000];
int cmp(const void *a,const void *b)
{
return *(int *)a-*(int *)b;
}
int dfs(int x)
{
int i,e;
int v[110];//应该定义到里边
if(sg[x]!=-1) return sg[x];
memset(v,0,sizeof(v));
for(i=0;i<n;i++)
{
if(x>=s[i])
{
dfs(x-s[i]);
v[sg[x-s[i]]]=1;
}
}
for(i=0;;i++)
{
if(!v[i])
{
e=i;
break;
}
}
return sg[x]=e;
}
int main()
{
int i,t;
while(scanf("%d",&n)!=EOF,n)
{
memset(sg,-1,sizeof(sg));
for(i=0;i<n;i++)
scanf("%d",&s[i]);
qsort(s,n,sizeof(s[0]),cmp);
/*for(i=0;i<n;i++)
printf("%d ",s[i]);*/
//	printf("\n");
scanf("%d",&t);
while(t--)
{
int c,sum=0;

scanf("%d",&c);
while(c--)
{
int num;
scanf("%d",&num);
sum^=dfs(num);
//	printf("sg[%d]=%d\n",num,sg[num]);
}
if(sum==0)
printf("L");
else
printf("W");
}
printf("\n");
}
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: