您的位置:首页 > 其它

Human Gene Functions - POJ 1080 UVaLive 2344 dp

2014-08-11 11:34 423 查看
Human Gene Functions

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 17014Accepted: 9463
Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because
these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.

One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many
researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene.

Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments
will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity

of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of

the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal

length. These two strings are aligned:

AGTGAT-G

-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.



denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG

-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the

similarity of the two genes is 14.
Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence
is at least one and does not exceed 100.
Output

The output should print the similarity of each test case, one per line.
Sample Input
2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA

Sample Output
14
21


题意:按照题目中给的图的方式匹配字符串,使其等长,然后找到权值和的最大值。

思路:dp[i][j][k]表示匹配第一个字符串的前i个和第二个字符串的前j个,并且匹配完后字符串的长度为k时的最大值。转移方程为

dp[i][j][k]=max(dp[i-1][j-1][k-1]+val[num1[i]][num2[j]],max(dp[i-1][j][k-1]+val[num1[i]][4],dp[i][j-1][k-1]+val[num2[j]][4]));

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF -1000000000
int dp[110][110][210],num1[110],num2[110];
char s1[110],s2[110];
int val[5][5]={5,-1,-2,-1,-3,
               -1,5,-3,-2,-4,
               -2,-3,5,-2,-2,
               -1,-2,-2,5,-1,
               -3,-4,-2,-1,0
               };
int len1,len2;
int main()
{ int t,n,m,i,j,k,ans;
  scanf("%d",&t);
  while(t--)
  { scanf("%d%s%d%s",&len1,s1+1,&len2,s2+1);
    for(i=1;i<=len1;i++)
    { if(s1[i]=='A') num1[i]=0;
      else if(s1[i]=='C') num1[i]=1;
      else if(s1[i]=='G') num1[i]=2;
      else if(s1[i]=='T') num1[i]=3;
    }
    for(i=1;i<=len2;i++)
    { if(s2[i]=='A') num2[i]=0;
      else if(s2[i]=='C') num2[i]=1;
      else if(s2[i]=='G') num2[i]=2;
      else if(s2[i]=='T') num2[i]=3;
    }
    for(i=0;i<=len1;i++)
     for(j=0;j<=len2;j++)
      for(k=0;k<=len1+len2;k++)
       dp[i][j][k]=INF;
    dp[0][0][0]=0;
    for(i=0;i<=len1;i++)
     for(j=0;j<=len2;j++)
      for(k=max(i,j);k<=i+j;k++)
      { if(i==0 && j==0)
         continue;
        else if(i==0)
         dp[i][j][k]=dp[i][j-1][k-1]+val[num2[j]][4];
        else if(j==0)
         dp[i][j][k]=dp[i-1][j][k-1]+val[num1[i]][4];
        else
         dp[i][j][k]=max(dp[i-1][j-1][k-1]+val[num1[i]][num2[j]],max(dp[i-1][j][k-1]+val[num1[i]][4],dp[i][j-1][k-1]+val[num2[j]][4]));
      }
    ans=INF;
    for(i=max(len1,len2);i<=len1+len2;i++)
     ans=max(ans,dp[len1][len2][i]);
    printf("%d\n",ans);
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: