您的位置:首页 > 其它

POJ-1751 Highways

2014-08-09 16:37 465 查看
[align=center]Highways[/align]

Time Limit: 1000MS Memory Limit: 10000K
  Special Judge
Description
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some
of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus
their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length.
Thus, the least expensive highway system will be the one that minimizes the total highways length.

Input
The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from
1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a
highway. Each pair of towns is connected by at most one highway.

Output
Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway
connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.

Sample Input
9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2


Sample Output
1 6
3 7
4 9
5 7
8 3

————————————————————集训9.6的分割线————————————————————
前言:血坑。ZOJ-2048和这道题除了一个是多组数据一个是单组数据之外一模一样。你懂得。

思路:首先要挨个计算权值,其次要改变修好的路权值为0。最后是输出路径,一个near数据就行了。

代码如下:

/*
ID: j.sure.1
PROG:
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <iostream>
#define INF 2e9
using namespace std;
/****************************************/
const int N = 1000;
int near
, X
, Y
;
double mat

, low
;
int n, m;

void prim()
{
for(int i = 1; i <= n; i++) {
low[i] = mat[1][i];
near[i] = 1;
}
near[1] = -1;
int k = -1;

for(int i = 2; i <= n; i++) {
double mini = INF;
for(int j = 1; j <= n; j++) if(near[j] != -1) {
if(mini > low[j]) {
k = j;
mini = low[j];
}
}

if(k != -1) {
if(mat[near[k]][k] != 0)
printf("%d %d\n", near[k], k);
near[k] = -1;
for(int j = 1; j <= n; j++) if(near[j] != -1) {
if(low[j] > mat[k][j]) {
near[j] = k;
low[j] = mat[k][j];
}
}
}
}

}

int main()
{
#ifdef J_Sure
freopen("1751.in", "r", stdin);
// freopen(".out", "w", stdout);
#endif
int T;
//scanf("%d", &T);
bool fir = false;
//while(T--) {
//memset(near, 0, sizeof(near));
//memset(low, 0, sizeof(low));
scanf("%d", &n);
for(int i = 1; i <= n; i++) {
scanf("%d%d", &X[i], &Y[i]);
}
for(int i = 1; i <= n; i++) {
for(int j = i+1; j <= n; j++) {
double d = sqrt(1.0 * ((X[i] - X[j])*(X[i] - X[j])
+ (Y[i] - Y[j])*(Y[i] - Y[j])));
mat[i][j] = mat[j][i] = d;
}
}
int road, a, b;
scanf("%d", &road);
for(int i = 0; i < road; i++) {
scanf("%d%d", &a, &b);
mat[a][b] = mat[b][a] = 0;
}
if(fir) puts("");fir = true;
prim();

//}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: