您的位置:首页 > 其它

POJ-1789 Truck History

2014-08-09 13:04 330 查看
[align=center]Truck History[/align]

Time Limit: 2000MS Memory Limit: 65536K
Description
Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string
of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from
the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different
letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input
The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase
letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output
For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input
4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0


Sample Output
The highest possible quality is 1/3.

————————————————————集训9.4的分割线————————————————————
思路:算是比较裸的prim题目了。既然质量最高,分母就最小。分母恰好是最小生成树的权。只不过每个点之间的权值需要for3次求出来而已。

代码如下:

/*
ID: j.sure.1
PROG:
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <iostream>
#define INF 2e9
using namespace std;
/****************************************/
const int N = 2005;
int n, m, dis

, lowcost
;
char code
[10];

int prim()
{
int sum = 0;
for(int i = 0; i < n; i++)
lowcost[i] = dis[0][i];
lowcost[0] = -1;
for(int i = 1; i < n; i++) {
int mini = INF;
int k;
for(int j = 0; j < n; j++) if(lowcost[j] != -1) {
if(mini > lowcost[j]) {
mini = lowcost[j];
k = j;
}
}
sum += mini;
lowcost[k] = -1;
for(int j = 0; j < n; j++) if(lowcost[j] != -1) {
lowcost[j] = min(lowcost[j], dis[k][j]);
}
}
return sum;
}

void cal_dis()
{
for(int i = 0; i < n; i++) {
for(int j = i+1; j < n; j++) {
for(int k = 0; k < 7; k++) {
if(code[i][k] != code[j][k]) {
dis[i][j]++; dis[j][i]++;
}
}
}
}
}

void init()
{
memset(dis, 0, sizeof(dis));
memset(lowcost, 0, sizeof(lowcost));
}

int main()
{
#ifdef J_Sure
freopen("1789.in", "r", stdin);
// freopen(".out", "w", stdout);
#endif
while(scanf("%d", &n)!=EOF&&n) {
for(int i = 0; i < n; i++)
scanf("%s", code[i]);
init();
cal_dis();
printf("The highest possible quality is 1/%d.\n", prim());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: