您的位置:首页 > 其它

hdu-oj 1164 Eddy's research I

2014-08-09 11:17 316 查看

Eddy's research I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6401    Accepted Submission(s): 3836


[align=left]Problem Description[/align]
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help
him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

 Output
You have to print a line in the output for each entry with the answer to the previous question.

 Sample Input

11
9412

 Sample Output

11
2*2*13*181 
#include <stdio.h>
#include <string.h>
#define MAXN 65535+10
int notprime[MAXN];
int isprime[MAXN];
int a[MAXN];
int main()
{  int n,i,j,k,m; memset(notprime,0,sizeof(notprime));
notprime[1]=1;notprime[0]=1;
for(i=2;i*i<MAXN;i++)
{  if(!notprime[i])
{  for(j=i*i;j<MAXN;j+=i)
notprime[j]=1;
}
}k=0;
for(i=0;i<=MAXN;i++)
if(!notprime[i])
isprime[k++]=i;
while(scanf("%d",&n)!=EOF&&n>0)
{    m=0;
for( i=0;i<k;i++)
{
while(n%isprime[i]==0)
{
n=n/isprime[i];
a[m++]=isprime[i];
}
}
for( i=0;i<m;i++)
{
if(i==0)
printf("%d",a[i]);
else
printf("*%d",a[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: