您的位置:首页 > 其它

poj 1426 Find The Multiple(bfs)

2014-08-09 10:58 344 查看
Find The Multiple

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 18023Accepted: 7303Special Judge
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing
no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them
is acceptable.
Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<queue>
#define N 50
using namespace std;
unsigned long long ans;
int dfs(unsigned long long a,unsigned long long b,int n  )
{
if(a>=b) return 0;
if(b%n==0)
{
ans = b;return 1;
}
if(dfs(b,b*10,n))
return 1;
return dfs(b,b*10+1,n);
}
int main()
{
int n;
while(cin >> n&&n)
{
if(dfs(0,1,n))
cout << ans << endl;
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: