您的位置:首页 > 其它

hdu 1049 Climbing Worm

2014-08-08 22:35 411 查看

Climbing Worm

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12288 Accepted Submission(s): 8291



Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and
resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.



Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end
of output.



Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.



Sample Input
10 2 1
20 3 1
0 0 0




Sample Output
17
19
/*题解:
    很水的题,不知为何归于贪心类型的。
    感觉自己完全没涉及到贪心啊 
     */
[code]#include<cstdio>
int main()
{
    int n,u,d,t,len;
    while(scanf("%d %d %d",&n,&u,&d)!=EOF)
    {
        if(n==0&&u==0&&d==0) break;
        len=t=0;
        while(len<n)
        {
            len+=u;
            t++;
            if(len>=n)
            {
                break;
            }
            else
            {
                t++;
                len-=d;
            }
        }
        printf("%d\n",t);
    }
    return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: