您的位置:首页 > 其它

HDOJ 题目3389 Game(阶梯博弈)

2014-08-08 21:13 501 查看

Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 367    Accepted Submission(s): 244


[align=left]Problem Description[/align]
Bob and Alice are playing a new game. There are n boxes which have been numbered from 1 to n. Each box is either empty or contains several cards. Bob and Alice move the cards in turn. In each turn the corresponding player should choose
a non-empty box A and choose another box B that B<A && (A+B)%2=1 && (A+B)%3=0. Then, take an arbitrary number (but not zero) of cards from box A to box B. The last one who can do a legal move wins. Alice is the first player. Please predict who will win the
game.
 

[align=left]Input[/align]
The first line contains an integer T (T<=100) indicating the number of test cases. The first line of each test case contains an integer n (1<=n<=10000). The second line has n integers which will not be bigger than 100. The i-th integer
indicates the number of cards in the i-th box.
 

[align=left]Output[/align]
For each test case, print the case number and the winner's name in a single line. Follow the format of the sample output.
 

[align=left]Sample Input[/align]

2
2
1 2
7
1 3 3 2 2 1 2

 

[align=left]Sample Output[/align]

Case 1: Alice
Case 2: Bob

 

[align=left]Author[/align]
hanshuai@whu
 

[align=left]Source[/align]
The 5th Guangting Cup Central China Invitational Programming
Contest
 

[align=left]Recommend[/align]
notonlysuccess   |   We have carefully selected several similar problems for you:  3387 3388 3390 3391 3393 
 

题意:有n个盒子编号为1-n,每个盒子里面有若干物品 
      当编号满足a>b && (a+b)%3==0 && (a+b)%2==1时 
      可以从a盒子中拿>=1个物品到b盒子中 
 
思路:找规律后转换为Staircase Nim 
      满足此条件:(a+b)%3==0 && (a+b)%2==1的即是3个倍数并且是奇数:3、9、15、21,即%6==3 
      每六个拆开后会发现如下3组可以传递的关系: 
      1<--2<--7<--8<--13<--14 
      3<--6<--9<--12<--15<--18 
      4<--5<--10<--11<--16<--17 
      即3组Staircase Nim,3组结果异或即可。 
虽然似懂非懂,先珍藏一下再说吧
ac代码
#include<stdio.h>
int main()
{
int t,c=0;
scanf("%d",&t);
while(t--)
{
int n,i,num[100000],s1=0,s2=0,s3=0,s;
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&num[i]);
for(i=2;i<=n;i+=6)
s1^=num[i];
for(i=6;i<=n;i+=6)
s2^=num[i];
for(i=5;i<=n;i+=6)
s3^=num[i];
s=s1^s2^s3;
if(s)
printf("Case %d: Alice\n",++c);
else
printf("Case %d: Bob\n",++c);
}
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: