您的位置:首页 > 运维架构

Pseudoprime numbers poj3641(快速幂+素数判定)

2014-08-08 20:47 411 查看
SubmitStatus

Description

Fermat's theorem states that for any prime number p and for any integer
a > 1, ap = a (mod p). That is, if we raise
a to the pth power and divide by p, the remainder is
a. Some (but not very many) non-prime values of p, known as base-a
pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all
a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not
p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing
p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0


Sample Output

no
no
yes
no
yes
yes
题意:给一个 p 和 一个 a,如果这个p 本身就是一个素数,就输出 no,如果不是素数,那么计算  ( a ^ p) % p 如果结果等于 a 那么输出 yes 否则输出 no
#include<stdio.h>
#include<iostream>
#include<memory.h>
#include<algorithm>
#include<math.h>
#define N 1000000000
using namespace std;
typedef long long ll;
int pri(ll n)
{
int i;
if(n==2)
return 0;
for(i=2;i*i<=n;i++)
if(n%i==0)
return 0;
return 1;
}
ll pow_mod(ll x,ll n,ll mod)
{
ll ans=1;
while(n)
{
if(n&1) ans=ans*x%mod;
x=x*x%mod;
n>>=1;
}
return ans;
}
int main()
{
ll p,a;
while(scanf("%I64d%I64d",&p,&a),p&&a)
{
if(pri(p)==1)
{
printf("no\n");
continue;
}
ll ans=pow_mod(a,p,p);
if(ans==a)
printf("yes\n");
else
printf("no\n");
}
return 0;

}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: