您的位置:首页 > 其它

1056. Mice and Rice (25)

2014-08-08 20:43 323 查看
Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG
winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG
mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1) where each Wi is the weight of the i-th mouse
respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:
5 5 5 2 5 5 5 3 1 3 5


分析:

(1)首先题目理解很纠结,注意2点,一点是 输入第三行是指第6号参赛者是第1个,不是第1号第6个比;第二点是,当遇到少于NG人时,比如两人,那么就晋级1人淘汰1人;

         正确理解题目有利于梳理输入输出的思路。

(2)本题可以用队列来做,但是我参考的是一个用vector的,正好学习下vector容器的使用。

         vector<int> ans,tmp;

        ans.push_back(x);

        ans.size()

        tmp.clear();

        ans.begin()

(3)思路:输入,不停比较直至ans只有一个元素,每轮淘汰的人的排名是有公式的,输出;

(4)循环的时候用了start和end作为标度,这个比较重要,用于在一个容器中分段处理。

(5)分清指针和实体。  比如ans.begin()是指针  ans[0]是第一个实体  用容器的时候要对这点敏感。

#include <cstdio>
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct node {
int value,rank;
};
node n[100000];
bool cmp(int x,int y){
return n[x].value>n[y].value;
}

int np,ng,x,i,j;
vector<int> ans,tmp;

int main (){
scanf("%d%d",&np,&ng);
for (i=0;i<np;i++){
scanf("%d",&n[i].value);
}
for (i=0;i<np;i++){
scanf("%d",&x);
ans.push_back(x);
}

while (ans.size()>1){ // ranking
int start=0,end=start+ng;
while (start<ans.size()){
x=ans.size()/ng+2;
if (ans.size()%ng==0) x--;
end=start+ng;
if (end>ans.size()) end=ans.size();
sort(ans.begin()+start,ans.begin()+end,cmp);
tmp.push_back(ans[start]);
for (i=start+1;i<end;i++){
n[ans[i]].rank=x;
}
start=end;
}
ans=tmp;
tmp.clear();
}
n[ans[0]].rank=1; //[0]differ from .begin()
printf("%d",n[0].rank);
for (i=1;i<np;i++){
printf(" %d",n[i].rank);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: