您的位置:首页 > 其它

UVA - 755 487--3279

2014-08-08 20:00 381 查看


 487-3279 
Businesses like to have memorable telephone numbers. One way to make a telephone number memorableis to have it spell a memorable word or phrase. For example, you can call the University of Waterloo bydialing the memorable TUT-GLOP. Sometimes only part of
the number is used to spell a word. Whenyou get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Anotherway to make a telephone number memorable is to group the digits in a memorable way. You couldorder your pizza from Pizza
Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third andfourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2

D, E, and F map to 3

G, H, and I map to 4

J, K, and L map to 5

M, N, and O map to 6

P, R, and S map to 7

T, U, and V map to 8

W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary.The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and thestandard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of thequality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input 

The first line of the input contains the number of datasets in the input. A blank line follows. The first line of each dataset specifies the number of telephone numbersin the directory (up to 100,000) as a positive integer alone on the line. The remaining lines
list thetelephone numbers in the directory, with each number alone on a line. Each telephone number consistsof a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactlyseven of the characters in the string will be digits
or letters. There's a blank line between datasets.

Output 

Generate a line of output for each telephone number that appears more than once in any form. Theline should give the telephone number in standard form, followed by a space, followed by the numberof times the telephone number appears in the directory. Arrange
the output lines by telephone numberin ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Print a blank line between datasets.

Sample Input 

1

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279


Sample Output 

310-1010 2
487-3279 4
888-4567 3

题意:
按照上面的规则 输出有重复的电话号码,
#include<iostream>
#include<ctype.h>
#include<string.h>
#include<algorithm>
#include<string>
#include<map>
#define N 1000
using namespace std;

char s[] = "22233344455566677778889999";

string str;

int main()
{
int n;
cin >> n;
while(n --)
{
int m ;
cin >> m;
cin.get();
map<string ,int>  cs ;
for(int i = 0 ;i < m ; i ++)
{
getline(cin, str);
str.erase(remove(str.begin(),str.end(),'-'),str.end());

for(int  i = 0 ;i < str.length(); i ++)

if(isupper(str[i]))
str[i] = s[str[i] - 'A'];
str.insert(3,"-");
cs[str] ++ ;

}
int flag  = 0 ;
for(map<string,int>::iterator  i = cs.begin(); i != cs.end(); ++ i){
if(i-> second > 1)
{
cout << i-> first  + " "<< i->second << endl;
flag  =1;
}

}

if(flag == 0)
cout << "No duplicates."<<endl;
if(n)
cout << endl;
}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva UVA - 755 487--3279