您的位置:首页 > 产品设计 > UI/UE

hdu 1509 Windows Message Queue(优先队列)

2014-08-08 15:53 330 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1509

[align=left]Problem Description[/align]
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue.
Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting
messages to and getting message from the message queue.
 

[align=left]Input[/align]
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter
and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

[align=left]Output[/align]
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
 

[align=left]Sample Input[/align]

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

 

[align=left]Sample Output[/align]

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

代码:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
struct  node
{
char name[50];
int num;
int qx;
int id;
friend bool operator<(node a,node b)
{
if(a.qx==b.qx)
return a.id>b.id;        //注意题目中的一个描述,当优先级相等时,先进的先出去
return a.qx>b.qx;
}
};
priority_queue<node>q;
int main()
{
//freopen("in.txt","r",stdin);
char s[5],name[50];
int num,qx;
int cnt=1;
while(scanf("%s",s)!=EOF)
{
if(!strcmp(s,"GET"))
{
if(q.empty())
printf("EMPTY QUEUE!\n");
else
{
node tmp=q.top();
q.pop();
printf("%s %d\n",tmp.name,tmp.num);
}
}
else
{
scanf("%s %d %d",name,&num,&qx);
node next;
strcpy(next.name,name);
next.num=num;
next.qx=qx;
next.id=cnt++;
q.push(next);
}
}
while(!q.empty())
q.pop();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: