您的位置:首页 > 其它

poj2407Relatives(欧拉公式,素因数分解)

2014-08-08 15:45 246 查看
Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0


Sample Output

6
4
题意求出在1到n之间与n互质的个数。
欧拉公式:φ(x)=x(1-1/p1)(1-1/p2)(1-1/p3)(1-1/p4)…..(1-1/pn),其中p1, p2……pn为x的所有质因数,x是不为0的整数。φ(1)=1(唯一和1互质的数(小于等于1)就是1本身)。
(注意:每种质因数只一个。比如12=2*2*3那么φ(12)=12*(1-1/2)*(1-1/3)=4
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;

long long euler(long long n){
long long ret=n;
for(long long i=2;i*i<=n;i++){
if(n%i==0){
ret-=ret/i;
while(n%i==0)n/=i;
}
}
if(n>1) ret-=ret/n;
return ret;
}
int main()
{
long long n;
while(scanf("%I64d",&n),n)
{
printf("%I64d\n",euler(n));
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: