您的位置:首页 > 其它

poj 1742 Coins (多重背包可行性问题)

2014-08-08 10:36 351 查看
Coins

Time Limit: 3000MSMemory Limit: 30000K
Total Submissions: 28659Accepted: 9731
Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change)
and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by
two zeros.
Output

For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output
8
4

Source

LouTiancheng@POJ

多重背包可行性,正常的三层循环算法会超时,通过添加t数组存每个硬币的使用次数,循环时判断是否超出c[i],可以降为o(n*v)的算法,大大减少时间,相当于拿空间换时间。

#include <cstdio>
#include <cstring>
int n,m,ans;
int v[105],c[105],t[100001];
bool p[100001];
int main()
{
while(scanf("%d%d",&n,&m),n){
for(int i=0;i<n;++i)scanf("%d",&v[i]);
for(int i=0;i<n;++i)scanf("%d",&c[i]);
memset(p,0,sizeof(p));
ans=0,p[0]=1;
for(int i=0;i<n;i++){
memset(t,0,sizeof(t));
for(int j=v[i];j<=m;++j)
if(!p[j]&&p[j-v[i]]&&t[j-v[i]]<c[i])t[j]=t[j-v[i]]+1,p[j]=1,++ans;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: