您的位置:首页 > 其它

POJ 3461 Oulipo (KMP)

2014-08-07 21:21 120 查看
Oulipo
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 23190Accepted: 9287
Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant
à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide
the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A','B',
'C', …, 'Z'} and two finite strings over that alphabet, a wordW and a text
T, count the number of occurrences of W inT. All the consecutive characters of W must exactly match consecutive characters ofT. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A','B',
'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the stringW).
One line with the text T, a string over {'A','B',
'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the wordW in the text
T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
***ERDXIVYERDIAN

Sample Output
1
3
0

Source
BAPC 2006 Qualification

题目链接 :http://poj.org/problem?id=3461

题目大意 :求解主串中有多少个子串与模式串匹配

题目分析 :KMP裸搞

#include <cstdio>
#include <cstring>
char text[1000005];
char word[10005];
int next[10005];

void get_next()  
{
    int j = -1, i = 0;
    next[0] = -1;
    while(word[i] != '\0')
    {
        if(j == -1 || word[j] == word[i])
        {
            j++;
            i++;
            if(word[j] == word[i])
                next[i] = next[j];
            else
                next[i] = j; 
        }
        else
            j = next[j];
    }
}

int KMP()
{
    get_next();
    int j = 0, i = 0;
    int ans = 0;
    int wlen = strlen(word);
    int tlen = strlen(text);
    while(i < tlen && j < wlen)
    {
        if(j != -1 && text[i] == word[j]) 
        {
            i++;
            j++;
       	}
        else if(j >= 0)     
            j = next[j];
        else
        {
            j++;
            i++;
        }
        if(j == wlen) 
        {
            ans++;
            j = next[j];
        }
    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(next,0,sizeof(next));
        scanf("%s%s",word,text);
        printf("%d\n",KMP());
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: