您的位置:首页 > 其它

hdu-1250-Hat's Fibonacci

2014-08-07 17:44 435 查看
[align=center]《BestCoder用户手册》下载
[/align]

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7496 Accepted Submission(s): 2432


[align=left]Problem Description[/align]
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.

F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)

Your task is to take a number as input, and print that Fibonacci number.

[align=left]Input[/align]
Each line will contain an integers. Process to end of file.

[align=left]Output[/align]
For each case, output the result in a line.

[align=left]Sample Input[/align]

100

[align=left]Sample Output[/align]

4203968145672990846840663646

import java.util.Scanner;
import java.math.*;
public class Main {
public static void main(String[] args){
Scanner in=new Scanner(System.in);
BigInteger a,b,c,d,e;

while(in.hasNext()){
a=b=c=d=BigInteger.ONE;
e=BigInteger.ZERO;
int n=in.nextInt();
if(n<=4) System.out.println("1");
else {
for(int i=0;i<n-4;i++){
e=BigInteger.ZERO;
e=e.add(a);
e=e.add(b);
e=e.add(c);
e=e.add(d);
a=b;b=c;c=d;d=e;
}
System.out.println(e);
}
}
in.close();
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: