您的位置:首页 > 其它

poj Corn Fields 3254 状态压缩dp

2014-08-07 16:43 393 查看
Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares
are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice
as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways
he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N

Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input
2 3
1 1 1
0 1 0

Sample Output
9

Hint

Number the squares as follows:

1 2 3
4


There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
Source

USACO 2006 November Gold

点值计算很重要

#include<stdio.h>

#include<string.h>

#include<iostream>

#include<algorithm>

using namespace std;

#define INF 100000000

int n,m,k;

int num[1<<13];

int dp[15][1<<13];

int Map[15];

bool ok(int x)

{

if(x&(x<<1))

return false;

return true;

}

void solve()

{

int i;

for(i=0;i<(1<<m);i++)

{

if(ok(i))

{

num[k++]=i;

// printf("%d\n",i);

}

}

// printf("%d\n",k);

}

int main()

{

int i,j;

int r,p;

int sum;

int point;

while(scanf("%d%d",&n,&m)!=EOF)

{

memset(num,0,sizeof(num));

memset(dp,0,sizeof(dp));

memset(Map,0,sizeof(Map));

for(i=0;i<n;i++)

for(j=0;j<m;j++)

{

scanf("%d",&point);

if(point==0)

Map[i]=(Map[i]|(1<<j));

}

k=0;

solve();

sum=0;

for(i=0;i<k;i++)

{

// printf("%d\n",num[i]);

if(num[i]&Map[0])

continue;

dp[0][i]=1;

// sum++;

}

// printf("%d\n",sum);

for(i=1;i<n;i++)

{

for(r=0;r<k;r++)

{

if(num[r]&Map[i])

continue;

for(p=0;p<k;p++)

{

if(num[r]&num[p])

continue;

dp[i][r]+=dp[i-1][p];

if(dp[i][r]>=INF)

dp[i][r]%=INF;

}

}

}

for(i=0;i<k;i++)

{

sum+=dp[n-1][i];

if(sum>=INF)

sum%=INF;

}

printf("%d\n",sum);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: