您的位置:首页 > 产品设计 > UI/UE

1051. Pop Sequence (25)

2014-08-07 16:22 393 查看
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain
1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow,
each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:
YES
NO
NO
YES
NO


分析:

(1)为什么我对栈那么木有感觉。。都不想看下去。OK,本题就是模拟栈。判断序列能否由堆栈出站完成。

(2)有两种方法,一种直接模拟。

         设cnt记录进入过站的最大值,temp是需要出栈的值,如果temp>cnt,则先入后出,否则直接出栈;

         采用stack。错误条件1,入栈后超过大小;2,出栈匹配。

(3)另外的方法见:http://blog.csdn.net/biaobiaoqi/article/details/9338397

#include <stdio.h>
#include <stack>
using namespace std;
int m,n,k,cnt,temp;
bool flag;
stack<int> s;
int main (){
scanf("%d %d %d",&m,&n,&k);
while(k--){
stack<int> s;
flag=true;
cnt=1;
s.push(1);
for (int i=0;i<n;i++){
scanf("%d",&temp);
if (temp>cnt){
for (int j=cnt+1;j<=temp;j++){
s.push(j);
}
if (s.size()>m){
flag=false;
}
cnt=temp;
}else {
if (s.top()!=temp){ //s.top not pop
flag=false; //continue; 因为S需要清除,修改后可加continue;
}
}
s.pop();
}
if (flag==true) printf ("YES\n");
else if (flag==false) printf ("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: