您的位置:首页 > 其它

HDU 1087-Super Jumping! Jumping! Jumping!(简单DP)

2014-08-07 10:11 573 查看
[align=left]Problem Description[/align]
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In
the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping
can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his
jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.

 

[align=left]Input[/align]
Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.

 

[align=left]Output[/align]
For each case, print the maximum according to rules, and one line one case.

 

[align=left]Sample Input[/align]

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

 

[align=left]Sample Output[/align]

4
10
3

                                                                 

题意:一组数字,从左到右选数,每次选的数应该比前一个选的数大,求出所能得到的最小值。

思路:DP~ 类似于最长上升子序列。

           外循环对整列数进行循环 i  ,内循环对i 前面的得到的DP值进行循环j ,将当下的n[i]与n[j]进行比较,大于的话就加上当前位置的dp[j] ,与dp[i]比较取最大值。

CODE:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

int n[1005];
int dp[1005];

int main()
{
//freopen("in.in","r",stdin);
int N;
while(~scanf("%d",&N),N){
for(int i=0;i<N;i++){
scanf("%d",&n[i]);
}
memset(dp,0,sizeof(dp));
int ans=-inf;
for(int i=0;i<N;i++){
dp[i]=n[i];
for(int j=0;j<i;j++){
if(n[j]<n[i])
dp[i]=max(dp[i],dp[j]+n[i]);
}
ans=max(ans,dp[i]);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU DP