您的位置:首页 > 其它

HDU 1074 Doing Homework(状态压缩dp)

2014-08-06 22:11 489 查看
Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final
test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject),
C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

Output

For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.

Sample Input

2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3


Sample Output

2
Computer
Math
English
3
Computer
English
Math

Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the
word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.


题目大意:有几门作业,给出了这门作业上交的期限,做这门作业消耗的时间,如果没按时交作业,老师会发飙,超一天扣一分,问完成这些作业最少被扣多少分,输出做作业顺序,字典序
这题可以想到是dp,再由n范围15,可以知道这题用状态压缩来做,就是用二进制数,01串表示每门作业做与不做,再结合巧妙地位运算,代码看起来有点麻烦但是弄懂了那几个位运算还是很好懂的,毕竟这本质只是一个很简单的dp,不懂位运算的百度百科

题目链接:点击打开链接

代码注释:

<pre name="code" class="cpp">#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 1<<16
#define inf 0x7ffffff
struct dp
{
int mincost; //最少的扣分
int day;//完成这些作业用的时间
int pre;//为了输出前面完成的作业
} dp
;
struct node
{
int deadline;//期限
int cost;//耗时
char name[100];
} course[16];
void print(int k,int t)
{
int v=k^t,c=-1;//这个k^t,^运算是,相同为0,不同为1,所以这里是找到第一个是1的地方,然后依次右移,c记录移了几次,就可以知道第几门作业写了
while(v)
{
v>>=1;
c++;
}
k=t;
t=dp[k].pre;
if(t!=-1)
print(k,t);//递归输出
printf("%s\n",course[c].name);
}
int main()
{
int T,i,j,n;
cin>>T;
while(T--)
{
cin>>n;
for(i=0; i<n; i++)
scanf("%s %d%d",course[i].name,&course[i].deadline,&course[i].cost);
for(i=1; i<(1<<n); i++)
dp[i].mincost=inf;
dp[0].mincost=dp[0].day=0;
dp[0].pre=-1;
for(i=0; i<(1<<n); i++)//i表示所有可能的情况,2^n种情况
for(j=0; j<n; j++)
{
int cell,cur,sub,all;
int tem=1<<j;
if((tem&i)==0)//表示写第j门作业满足这种列举的状态,这里其实是暴力列举了所有状态,依次匹配,找到写了哪些作业
{
cell=tem|i;//写第j门作业这个状态在i这种状态中
cur=dp[i].day+course[j].cost;//目前的消耗
sub=cur-course[j].deadline;//看扣多少分
if(sub<0)
sub=0;//为负表示能在期限前完成
all=sub+dp[i].mincost;
if(all<dp[cell].mincost)//更新dp
{
dp[cell].mincost=all;
dp[cell].pre=i;
dp[cell].day=cur;
}
}
}
printf("%d\n",dp[(1<<n)-1].mincost);
int k=(1<<n)-1;
int t=dp[k].pre;
print(k,t);//递归查找写了哪些作业,输出
}
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: