您的位置:首页 > 其它

HDU 1358——Period(KMP 失配函数)

2014-08-06 20:45 489 查看


Period

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2965 Accepted Submission(s): 1486



Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is
one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.



Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on
it.



Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing
order. Print a blank line after each test case.



Sample Input

3
aaa
12
aabaabaabaab
0




Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4




————————————————————————————————————————————————————

题意:

给定一个长度为n的字符串s,求一个最大的整数K>1 ,使得s的前i个字符组成的前缀是某个字符串重复K次得到,输出所有存在K的 i 和对应的 K

思路:

如果一个字串是循环串,那么i%(i-next[i])==0 ,循环的次数为i/(i-next[i]),又k>1 所以next[i]>0

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cstdlib>
#define M  1000000+10
using namespace std;
char str[M];
int f[M];
void get_next(char *p)
{
    int l=strlen(p);
    f[0]=-1;
    int j=-1,i=0;
    while(i<l){
        if(j==-1||p[i]==p[j]){
            i++;
            j++;
            f[i]=j;
        }
        else j=f[j];
    }
}
int main()
{
    int n;
    int cas=1;
    while(scanf("%d",&n),n){
        scanf("%s",str);
        get_next(str);
        printf("Test case #%d\n",cas++);
        for(int i=2;i<=n;++i){
            if(f[i]>0&&i%(i-f[i])==0) printf("%d %d\n",i,i/(i-f[i]));
        }
        printf("\n");
    }
    return 0;
}


12332
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: