您的位置:首页 > 其它

poj 3630 Phone List 字典树

2014-08-06 20:21 387 查看
点击打开链接题目链接

Phone List

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 22602Accepted: 6974
Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

Emergency 911
Alice 97 625 999
Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone
number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output
NO
YES


用指针会tle 用数组模拟188ms

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<stdlib.h>
using namespace std;
struct node
{
    int next[10];
    int flag;
};
node queue[100000];
int is;
int head=0;
char str[11];
void tree_add(char *str)
{
    int s;
    s=0;
    int i,j;
    int id;
    int l=strlen(str);
    int z,y;
    z=y=0;
    for(i=0;i<l;i++)
    {
        id=str[i]-'0';
        if(queue[s].next[id]==-1)
        {
            z=1;
            queue[s].next[id]=++head;
            s=head;
        }
        else
        {
            s=queue[s].next[id];
            if(queue[s].flag)
                y=1;
        }
    }
    queue[s].flag=1;
    is=!y&&z;
}
int main()
{
    int t,n;
    int i,j;
    scanf("%d",&t);
        while(t--)
        {
            head=0;
            for(i=0;i<100000;i++)
            {
                queue[i].flag=0;
                for(j=0;j<10;j++)
                queue[i].next[j]=-1;
            }
            is=1;
            scanf("%d",&n);
            for(i=0;i<n;i++)
            {
                scanf(" %s",str);
                if(is==1)
                tree_add(str);
            }
            if(is==0)
                printf("NO\n");
            else printf("YES\n");
        }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: