您的位置:首页 > 其它

hdu 1075 What Are You Talking About 字典树

2014-08-06 20:07 344 查看
点击打开链接题目链接


What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 102400/204800 K (Java/Others)

Total Submission(s): 13719 Accepted Submission(s): 4409



Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help
him?



Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains
two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single
line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new
word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single
string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.



Output

In this problem, you have to output the translation of the history book.



Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END




Sample Output

hello, i'm from mars.
i like earth!

Hint
Huge input, scanf is recommended.



翻译 如果输入的火星文有对应的英文 翻译 否则输出原字符串
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
char s1[3100],s2[15];
struct node
{
    node *next[26];
    char ans[11];
    int end;
    node()
    {
        end=0;
        for(int i=0;i<26;i++)
            next[i]=NULL;
    }
};
node *head;
void tree_add(char *s1,char *s2)
{
    node *t,*s=head;
    int l=strlen(s2);
    int id;
    int i,j;
    for(i=0;i<l;i++)
    {
        id=s2[i]-'a';
        if(s->next[id]==NULL)
        {
            t=new node;
            s->next[id]=t;
        }
        s=s->next[id];
    }
    strcpy(s->ans,s1);
    s->end=1;
}
int tree_search(char *s1)
{
    node *s=head;
    int i,id;
    int l=strlen(s1);
    for(i=0;i<l;i++)
    {
        id=s1[i]-'a';
        if(s->next[id]==NULL)
        {
            return 0;
        }
        s=s->next[id];
    }
    if(s->end==1)
    {
            printf("%s",s->ans);
            return 1;
    }
    return 0;
}
int main()
{
    head=new node;
    int i,j;
    int s;
    scanf("%s",s1);
    while(scanf("%s",s1)&&strcmp(s1,"END")!=0)
    {
        scanf("%s",s2);
        tree_add(s1,s2);
    }
    scanf("%s",s1);
    getchar();
    while(gets(s1)!=NULL)
    {
        if(strcmp(s1,"END")==0)
           break;
        int l=strlen(s1);
        s=0;
        for(i=0;i<l;i++)
        {
            while(s1[i]>='a'&&s1[i]<='z')
            {
                s2[s++]=s1[i++];
            }
            s2[s]='\0';
            if(tree_search(s2)==0)
                printf("%s",s2);
            printf("%c",s1[i]);
            s=0;
        }
        printf("\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: