您的位置:首页 > 大数据 > 人工智能

杭电2124 Repair the Wall

2014-08-06 11:34 375 查看

Repair the Wall

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2082 Accepted Submission(s): 1009



Problem Description
Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.

When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood.

One day, Kitty found that there was a crack in the wall. The shape of the crack is

a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.

The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired
perfectly, without any gap.

Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?



Input
The problem contains many test cases, please process to the end of file( EOF ).

Each test case contains two lines.

In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which

mentioned above.

In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).



Output
For each test case , print an integer which represents the minimal number of blocks are needed.

If Kitty could not repair the wall, just print "impossible" instead.



Sample Input
5 3
3 2 1
5 2
2 1




Sample Output
2
impossible[code]#include<stdio.h>
#include<algorithm>
using namespace std;
bool cmp(__int64 a,__int64 b)
{
return a>b;
}
int main()
{
    __int64 L,N;
    __int64 Sti[650];
    while(scanf("%I64d%I64d",&L,&N)!=EOF)
    {
      __int64 sumL=0;
     for(int i=0;i<N;i++)
     {
        scanf("%I64d",&Sti[i]); 
        sumL+=Sti[i];    
     }
     if(sumL<L)
     {
        printf("impossible\n");
        continue;                 
     }
     sort(Sti,Sti+N,cmp);
     sumL=0;
     for(int i=0;i<N;i++)
     {
      sumL+=Sti[i];
      if(sumL>=L)
      {
       printf("%d\n",i+1);
       break;
      }
     }
    }
return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: