您的位置:首页 > 产品设计 > UI/UE

[ACM] POJ 1141 Brackets Sequence (区间动态规划)

2014-08-06 10:02 387 查看
Brackets Sequence

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25087 Accepted: 7069 Special Judge
Description

Let us define a regular brackets sequence in the following way: 

1. Empty sequence is a regular sequence. 

2. If S is a regular sequence, then (S) and [S] are both regular sequences. 

3. If A and B are regular sequences, then AB is a regular sequence. 

For example, all of the following sequences of characters are regular brackets sequences: 

(), [], (()), ([]), ()[], ()[()] 

And all of the following character sequences are not: 

(, [, ), )(, ([)], ([(] 

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2
... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.
Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.
Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.
Sample Input
([(]

Sample Output
()[()]

Source

Northeastern Europe 2001

解题思路:
dp[i][j] 代表从i到j位置中至少添加几个括号使得括号匹配,pos[i][j]= -1,说明 str[i] str[j]是一对匹配的括号,否则记录的是从哪个位置把str[i].....str[j]分为两部分,输出答案采用递归的形式。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=220;
const int inf=0x7fffffff;
int pos[maxn][maxn];//从i到j在哪里分开
int dp[maxn][maxn];//从i到j至少添几个符号
char str[maxn];
int len;

void print(int i,int j)
{
if(i>j)
return ;//递归出口
if(i==j)
{
if(str[i]=='('||str[i]==')')
cout<<"()";
else
cout<<"[]";
}
else if(pos[i][j]==-1)//两边是对称的
{
cout<<str[i];
print(i+1,j-1);
cout<<str[j];
}
else//可分割
{
print(i,pos[i][j]);
print(pos[i][j]+1,j);
}
}

int main()
{
cin>>str;
len=strlen(str);
memset(dp,0,sizeof(dp));
for(int i=0;i<len;i++)
dp[i][i]=1;
for(int k=1;k<len;k++)//长度
for(int i=0;i+k<len;i++)//起点
{
int j=i+k;
dp[i][j]=inf;
if((str[i]=='('&&str[j]==')')||(str[i]=='['&&str[j]==']'))
{
dp[i][j]=dp[i+1][j-1];
pos[i][j]=-1;//暂时让它等于-1
}
for(int mid=i;mid<j;mid++)//这个必须要执行的。
{
if(dp[i][j]>(dp[i][mid]+dp[mid+1][j]))
{
dp[i][j]=dp[i][mid]+dp[mid+1][j];
pos[i][j]=mid;
}
}
}
print(0,len-1);
cout<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: