您的位置:首页 > 其它

An easy problem(2055)

2014-08-06 09:55 218 查看

An easy problem

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13691 Accepted Submission(s): 9242



Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;

Give you a letter x and a number y , you should output the result of y+f(x).

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

Output
for each case, you should the result of y+f(x) on a line.

Sample Input
6
R 1
P 2
G 3
r 1
p 2
g 3


Sample Output
19
18
10
-17
-14
-4

-------------------------------------------------------------------------------

F1:
#include<stdio.h>
#include<string.h>
int main()
{
    int n,m;
    char c;
    scanf("%d",&n);
    while(n--)
    {
    getchar();
    scanf("%c%d",&c,&m);
    if(c>=65&&c<=90)
        printf("%d\n",c-64+m);
         if(c>=97&&c<=122)
        printf("%d\n",96-c+m);
    }
    return 0;

}

----------------------------------------------------F2:

#include<stdio.h>#include<ctype.h>int main(){       int t,y;       char x;       scanf("%d%*c",&t);       while (t--)       {              scanf("%c%d%*c",&x,&y);              if (isupper(x)==1)                    printf("%d\n",x-64+y);              else                    printf("%d\n",96-x+y);            }       return 0;}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: