您的位置:首页 > 其它

HDU 1754 I Hate It(线段树,单点更新)

2014-08-06 00:52 483 查看
B - I Hate It
Time Limit:3000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status

Description

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input

本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

Output

对于每一次询问操作,在一行里面输出最高成绩。

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output

5
6
5
9

Hint

Huge input,the C function scanf() will work better than cin


这道题和HDU1166敌兵布阵差不多
同样也是线段树入门题,学习如何创建线段树,更行线段树,查询线段树

#include<cstdio>
#include<iostream>
#include<cstring>
#include<stack>
#include<queue>
#include<cmath>
#include<stdlib.h>
#include<algorithm>
using namespace std;
const int MAXN=200000+5;
struct node
{
int l,r;
int num;
int mid()
{
return (l+r)>>1;
}
}a[MAXN*5];
int b[MAXN];

void btree(int l,int r,int step)
{
a[step].l=l;
a[step].r=r;
if(l==r)
{
a[step].num=b[l];
return ;
}
int mid=a[step].mid();
btree(l,mid,step*2);
btree(mid+1,r,step*2+1);
a[step].num=max(a[step*2].num,a[step*2+1].num);
}

void update(int index,int val,int step)
{
if(a[step].l==a[step].r && a[step].l==index)
{
a[step].num=val;
return ;
}
int mid=a[step].mid();
if(index>mid) update(index,val,step*2+1);
else update(index,val,step*2);
a[step].num=max(a[step*2].num,a[step*2+1].num);
}

int query(int x,int y,int step)
{
if(x<=a[step].l && a[step].r<=y) return a[step].num;
int mid=a[step].mid();
if(x>mid) return query(x,y,step*2+1);
else if(y<=mid) return query(x,y,step*2);
else return max(query(x,y,step*2),query(x,y,step*2+1));
}
/*
void display(int l,int r,int step)
{
if(l==r)
{
printf("a[%d]=%d\n",l,a[step].num);
return ;
}
int mid=a[step].mid();
display(l,mid,step*2);
display(mid+1,r,step*2+1);
}*/
int main()
{
int n,m;
while(scanf("%d %d",&n,&m)!=EOF)
{
for(int i=1;i<=n;i++) scanf("%d",&b[i]);
btree(1,n,1);
char str[10];
int A,B;
while(m--)
{
scanf("%s %d %d",str,&A,&B);
if(str[0]=='U') {update(A,B,1);}
if(str[0]=='Q') printf("%d\n",query(A,B,1));
}
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: