您的位置:首页 > 编程语言 > C语言/C++

HDOJ 2736 Surprising Strings——c++STL(map)

2014-08-05 19:51 351 查看


Surprising Strings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 349    Accepted Submission(s): 245


Problem Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance
D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG
is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

 

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

 

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

 

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

 

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

 

Source

Mid-Central USA 2006

#include <stdio.h>
#include <string.h>
#include <string>
#include <map>

using namespace std;

int main()
{
char str[81];
char s[3];
map <string,int> mp;
map <string,int>::iterator it;
int l,i,j,flag;
while(gets(str),str[0]!='*')
{
l=strlen(str);
flag=0;
for(i=1;i<l;i++)
{
for(j=0;j+i<l;j++)
{
s[0]=str[j];
s[1]=str[j+i];
s[2]='\0'; //起初这个地方没注意,结果一直不对
mp[s]++;
}
for(it=mp.begin();it!=mp.end();it++)
{
if(it->second>=2)
{
flag=1;
break;
}
}
mp.clear();
if(flag)
break;
}
if(flag)
printf("%s is NOT surprising.\n",str);
else
printf("%s is surprising.\n",str);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: