您的位置:首页 > 其它

UVA 10361 - Automatic Poetry(<>里字符串交换)

2014-08-05 19:43 309 查看


Automatic Poetry

Input: standard input
Output: standard output
Time Limit: 2 seconds
Memory Limit: 32 MB



“Oh God”, Lara Croft exclaims, “it’s one of these dumb riddles again!”

In Tomb Raider XIV, Lara is, as ever, gunning her way through ancient Egyptian pyramids, prehistoric caves and medival hallways. Now she is standing in front of some important Germanic looking doorway
and has to solve a linguistic riddle to pass. As usual, the riddle is not very intellectually challenging.

This time, the riddle involves poems containing a “Schuttelreim”. An example of a Schuttelreim is the following short poem:

Ein Kind halt seinen Schnabel nur,
wenn es hangt an der Nabelschnur.

/*German contestants please forgive me. I had to modify something as they were not appearing correctly in plain text format*/

A Schuttelreim seems to be a typical German invention. The funny thing about this strange type of poetry is that if somebody gives you the first line and the beginning of the second one, you can complete
the poem yourself. Well, even a computer can do that, and your task is to write a program which completes them automatically. This will help Lara concentrate on the “action” part of Tomb Raider and not on the “intellectual” part.

Input

The input will begin with a line containing a single number n. After this line follow n pairs of lines containing Schuttelreims. The first line of each pair will be of the form
s1<s2>s3<s4>s5

where the si are possibly empty, strings of lowercase characters or blanks. The second line will be a string of lowercase characters or blanks ending with three dots “...”. Lines will we at
most 100 characters long.

Output

For each pair of Schuttelreim lines l1 and l2 you are to output two lines c1 and c2 in the following way: c1 is the same as l1 only
that the bracket marks “<” and “>” are removed. Line c2 is the same as l2 , except that instead of the three dots the string s4s3s2s5 should appear.

Sample Input

3

ein kind haelt seinen <schn>abel <n>ur

wenn es haengt an der ...

weil wir zu spaet zur <>oma <k>amen

verpassten wir das ...

<d>u <b>ist

...

Sample Output

ein kind haelt seinen schnabel nur
wenn es haengt an der nabel schnur
weil wir zu spaet zur oma kamen
verpassten wir das koma amen
du bist
bu dist

题目大意:两个< >里面的字符交换。

解题思路:
把字符串分成5个部分。

代码:

#include<iostream>
#include<cstdio>
#include<string>
using namespace std;

int n;
string l1,l2;
char s[5][110];

void solve(){
    int k1=0,k2=0;
    for(int i=0;i<l1.length();i++){
        if(l1[i]=='<'||l1[i]=='>'){
            s[k1][k2]='\0';
            k2=0;
			k1++;
        }
        else{
			s[k1][k2++]=l1[i];
		}
    }
	s[k1][k2]='\0';
    printf("%s%s%s%s%s\n",s[0],s[1],s[2],s[3],s[4]);
    for(int i=0;i<l2.length();i++){
        if(l2[i]=='.')
			break;
        cout<<l2[i];
    }
    printf("%s%s%s%s\n",s[3],s[2],s[1],s[4]);
}

int main(){
    cin>>n;
    getchar();
    while(n-->0){
        getline(cin,l1);
        getline(cin,l2);
        solve();
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐