您的位置:首页 > 其它

POJ1106-Transmitters

2014-08-05 16:58 459 查看
Transmitters

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4555 Accepted: 2427
Description
In a wireless network with multiple transmitters sending on the same frequencies, it is often a requirement that signals don't overlap, or at least that they don't conflict. One way of accomplishing this is to restrict
a transmitter's coverage area. This problem uses a shielded transmitter that only broadcasts in a semicircle. 

A transmitter T is located somewhere on a 1,000 square meter grid. It broadcasts in a semicircular area of radius r. The transmitter may be rotated any amount, but not moved. Given N points anywhere on the grid, compute the maximum number of points that can
be simultaneously reached by the transmitter's signal. Figure 1 shows the same data points with two different transmitter rotations. 



All input coordinates are integers (0-1000). The radius is a positive real number greater than 0. Points on the boundary of a semicircle are considered within that semicircle. There are 1-150 unique points to examine per transmitter. No points are at the same
location as the transmitter. 

Input
Input consists of information for one or more independent transmitter problems. Each problem begins with one line containing the (x,y) coordinates of the transmitter followed by the broadcast radius, r. The next line contains
the number of points N on the grid, followed by N sets of (x,y) coordinates, one set per line. The end of the input is signalled by a line with a negative radius; the (x,y) values will be present but indeterminate. Figures 1 and 2 represent the data in the
first two example data sets below, though they are on different scales. Figures 1a and 2 show transmitter rotations that result in maximal coverage.
Output
For each transmitter, the output contains a single line with the maximum number of points that can be contained in some semicircle.
Sample Input
25 25 3.5
7
25 28
23 27
27 27
24 23
26 23
24 29
26 29
350 200 2.0
5
350 202
350 199
350 198
348 200
352 200
995 995 10.0
4
1000 1000
999 998
990 992
1000 999
100 100 -2.5

Sample Output
3
4
4

Source
Mid-Central USA 2001
//AC代码
/*
题意:在1000x1000的平面指教坐标系中有n个点,现在有一个可以旋转的半圆(圆心已给出),半径为R,问半圆最多可以覆盖多少个点
此题首先可以排除和圆心距离大于R的点,然后符合条件的点逐个和圆心连成一条直线,然后用叉积暴力
*/
#include<iostream>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iomanip>
#include<map>
#include<cstdlib>
#include<cmath>
#include<vector>
#define LL long long
#define IT __int64
#define zero(x) fabs(x)<eps
#define mm(a,b) memset(a,b,sizeof(a))
const int INF=0x7fffffff;
const double inf=1e8;
const double eps=1e-10;
const double PI=acos(-1.0);
const int Max=151;
using namespace std;
int sign(double x)
{
return (x>eps)-(x<-eps);
}
typedef struct Node
{
double x;
double y;
double r;
Node(const double &_x=0, const double &_y=0) : x(_x), y(_y) {}
void input()
{
cin>>x>>y;
}
void output()
{
cout<<x<<" "<<y<<endl;
}
}point;
point node[Max],s[Max];
double xmult(point p0,point p1,point p2)
{
return(p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}
double dmult(point p0,point p1,point p2)
{
return(p1.x-p0.x)*(p2.x-p0.x)+(p1.y-p0.y)*(p2.y-p0.y);
}
double Distance(point p1,point p2)// 返回两点之间欧氏距离
{
return( sqrt( (p1.x-p2.x)*(p1.x-p2.x)+(p1.y-p2.y)*(p1.y-p2.y) ) );
}
bool cmp(point u,point v)
{
if(u.y>=v.y)
{
if(u.x<v.x)
return true;
}
}
int main()
{
int n,m,i,j;
point R,xx,yy;
int sum,num;
while(cin>>R.x>>R.y>>R.r&&(R.r>=0))
{
cin>>n;
m=0;
for(i=0;i<n;i++)
{
node[i].input();
if(Distance(node[i],R)<=R.r)
s[m++]=node[i];
}
num=0;
for(i=0;i<m;i++)
{
//xx.x=R.x-s[i].x;
//xx.y=R.y-s[i].y;
sum=1;
for(j=0;j<m;j++)
{
if(i!=j)
{
//yy.x=R.x-s[j].x;
//yy.y=R.y-s[j].y;
if(xmult(R,s[i],s[j])<=0)
sum++;
}
}
num=max(num,sum);
}
cout<<num<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  解析几何