您的位置:首页 > 其它

UVA - 10878 Decode the tape

2014-08-05 11:12 381 查看
 

"Machines take me by surprise with great frequency."
Alan Turing

Your boss has just unearthed a roll of old computer tapes. The tapes have holes in them and might contain some sort of useful information. It falls to you to figure out what is written on them.

Input

The input will contain one tape.

Output

Output the message that is written on the tape.

Sample Input

___________
| o   .  o|
|  o  .   |
| ooo .  o|
| ooo .o o|
| oo o.  o|
| oo  . oo|
| oo o. oo|
|  o  .   |
| oo  . o |
| ooo . o |
| oo o.ooo|
| ooo .ooo|
| oo o.oo |
|  o  .   |
| oo  .oo |
| oo o.ooo|
| oooo.   |
|  o  .   |
| oo o. o |
| ooo .o o|
| oo o.o o|
| ooo .   |
| ooo . oo|
|  o  .   |
| oo o.ooo|
| ooo .oo |
| oo  .o o|
| ooo . o |
|  o  .   |
| ooo .o  |
| oo o.   |
| oo  .o o|
|  o  .   |
| oo o.o  |
| oo  .  o|
| oooo. o |
| oooo.  o|
|  o  .   |
| oo  .o  |
| oo o.ooo|
| oo  .ooo|
|  o o.oo |
|    o. o |
___________
Sample Output
A quick brown fox jumps over the lazy dog.

题意:
给你一段明文和译文,然后进行解码。
观察可以知道,把‘0’看成 1,其他都当作0,那么就是它的二进制 ,而这一个二进制正好是对应字符的ASCII码的值
#include<stdio.h>
#include<iostream>
#include<string.h>

using namespace std;

int a[]={0,0,64,32,16,8,0,4,2,1,0};

int main(){
char b[20];
gets(b);
int n;
while(gets(b) && b[0] != '_'){
n = 0;
int len = strlen (b);
for(int i = 2;i < len; i ++){
if(b[i] == 'o')
n += a[i];
}
printf("%c",n);
}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息