您的位置:首页 > 其它

POJ 2777 Count Color

2014-08-05 10:42 423 查看
DescriptionChosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.
2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.
InputFirst line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.OutputOuput results of the output operation in order, each line contains a number.Sample Input
2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2
Sample Output
2
1
SourcePOJ Monthly--2006.03.26,dodo

线段树区间更新,位运算计算颜色种类的方法很吊,其他倒没什么
#include<stdio.h>
#include<string.h>
#define maxn 100000

struct node
{
	int l,r;
	int color;
	int add;
}tree[3*maxn];

void pushdown(int p)
{
	if(tree[p].add)
	{
		tree[p<<1].add=tree[p].add;
		tree[p<<1|1].add=tree[p].add;
		tree[p<<1].color=tree[p].color;
		tree[p<<1|1].color=tree[p].color;
		tree[p].add=0;
	}
}

void build(int p,int l,int r)
{
	tree[p].l=l;
	tree[p].r=r;
	tree[p].color=1;
	tree[p].add=1;
	if(l==r)
	  return ;
    int mid=(l+r)>>1;
    build(p<<1,l,mid);
    build(p<<1|1,mid+1,r);
}

void update(int p,int l,int r,int val)
{
	if(l<=tree[p].l && tree[p].r<=r)
	{
		tree[p].color=val;
		tree[p].add=1;
		return ; 
	}
	pushdown(p);
	int mid=(tree[p].l+tree[p].r)>>1;
	if(r<=mid)
	   update(p<<1,l,r,val);
    else if(l>mid)
       update(p<<1|1,l,r,val);
    else
    {
    	update(p<<1,l,mid,val);
    	update(p<<1|1,mid+1,r,val);
    }
    tree[p].color=tree[p<<1].color|tree[p<<1|1].color;
}

int sum=0;
void  query(int p,int l,int r)
{
	
	if(l<=tree[p].l && r>=tree[p].r)
	{
		sum|=tree[p].color;
		return ;
	}
	pushdown(p);
	int mid=(tree[p].l + tree[p].r)>>1;
	if(r<=mid)
	   query(p<<1,l,r);
	else if(l>mid)
	   query(p<<1|1,l,r);
    else
    {
    	query(p<<1,l,mid);
    	query(p<<1|1,mid+1,r);
    }
}
int answer()
{
	int ans=0;
	while(sum)
	{
		if(sum&1)
		   ans++;
        sum>>=1;
	}
	return ans;
}
int main()
{
	int l,t,o;
	while(~scanf("%d%d%d",&l,&t,&o))
	{
		char op;
		build(1,1,l);
		getchar();
		int x,y,z;
		for(int i=0;i<o;i++)
		{
			scanf("%c",&op);
			if(op=='C')
			{
				scanf("%d%d%d",&x,&y,&z);
				if(x>y)
				{
					x=x^y;
					y=x^y;
					x=x^y;
				}
				update(1,x,y,1<<(z-1));
			}
			else
			{
				scanf("%d%d",&x,&y);
				if(x>y)
				{
					x=x^y;
					y=x^y;
					x=x^y;
				}
				sum=0;
				query(1,x,y);
				printf("%d\n",answer());	
			}
			getchar();
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: