您的位置:首页 > 其它

hdu-oj 1194 Beat the Spread!

2014-08-05 09:35 495 查看

Beat the Spread!

Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4510    Aepteccd Submission(s): 2348
Time

[align=left]Problem Description[/align]
Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two
final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?

 
[align=left]Input[/align]
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final
scores. 
[align=left]Output[/align]
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers. 
[align=left]Sample Input[/align]

2
40 20
20 40 

[align=left]Sample Output[/align]

30 10
impossible

题目中文翻译:

超級盃又來了,為了打發中場休息時間,大家就來下注最後的結果會如何。大家下注的目標為兩隊最後的分數和,或者兩隊最後分數差的絕對值。 給你這2個值,你能推出這2隊最後的得分是多少嗎?

Input輸入的第一列有一個整數,代表以下有多少組測試資料。每組測試資料一列,有2個大於等於 0 的整數 s, d,s 代表比賽結束時2隊分數的總和, d 代表比賽結束時2隊分數差的絕對值。

Output對每組測試資料輸出一列,包含2個整數代表比賽結束時這2隊的分數,分數大的在前。如果沒有這樣的分數,請輸出「 impossible」。

請記得:美式足球的分數一定是大於等於 0 的整數。陷阱为如输入100 1,是没有2个整数相加为偶数相减为奇数的。。

附代码:

#include<stdio.h>
int main()
{
int n,a,b;
scanf("%d",&n);
while(n--)
{
scanf("%d%d",&a,&b);
if((a%2==0&&b%2!=0)||(a%2!=0&&b%2==0)||(a<=b))
//陷阱//不可能一个偶数和一个奇数的和是偶数,而差是奇数,(或者和是奇数,差是偶数)
{
printf("impossible\n");
}
else
{
printf("%d %d\n",a-(a-b)/2,(a-b)/2);
}
}
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: