您的位置:首页 > 其它

hdu-oj 1170 Balloon Comes!

2014-08-05 09:21 453 查看

Balloon Comes!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 19712    Accepted Submission(s): 7420


Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.

Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.

Is it very easy?

Come on, guy! PLMM will send you a beautiful Balloon right now!

Good Luck!

Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of
course, we all know that A and B are operands and C is an operator.

 Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.

Sample Input

4
+ 1 2
- 1 2
* 1 2
/ 1 2

 Sample Output

3
-1
2
0.50题目大意:编写简单计算器;解题思路:用switch 或if 判断字符,进行运算。注意:遇到“/”时,如果可以整除则输出整型数据,否则浮点型。附代码:
#include <stdio.h>
int main()
{  int a,b,n;
char c;
scanf("%d",&n);
getchar();//吸收回车键
while(n--){
scanf("%c%d%d",&c,&a,&b);
switch (c){
case '+': {printf("%.d\n",a+b);break;}
case '-': {printf("%d\n",a-b);break;}
case '*': {printf("%d\n",a*b);break;}
case '/': {a%b?printf("%.2lf\n",a*1.0/b):printf("%d\n",a/b);break;}
}
getchar();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: