您的位置:首页 > 其它

HDU 1544 Palindromes(判断是否为回文序列和镜像序列)

2014-08-04 15:43 423 查看
Palindromes
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld
& %llu

Description

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when
the string is read from right to left.



A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored
string because "A" and "I"are their own reverses, and "3" and "E" are each others' reverses.

A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string"ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and
because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string.

Of course,"A","T", "O",
and "Y" are all their own reverses.

A list of all valid characters and their reverses is as follows.

CharacterReverseCharacterReverseCharacterReverse
AAMMYY
BNZ5
COO11
DP2S
E3Q3E
FR4
GS25Z
HHTT6
IIUU7
JLVV88
KWW9
LJXX
Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRINGCRITERIA
" -- is not a palindrome."if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."if the string is a palindrome and is a mirrored string
Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA


Sample Output

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.


Hint

use the C++'s class of string will be convenient, but not a must。

题目大意:

判断字符串是回文串还是反射串。

解题思路:

利用map。

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<map>

using namespace std;

map <char,char>mp;
string str;

void initial(){
    mp['A']='A';mp['B']=' ';mp['C']=' ';mp['D']=' ';mp['E']='3';mp['F']=' ';mp['G']=' ';
    mp['H']='H';mp['I']='I';mp['J']='L';mp['K']=' ';mp['L']='J';mp['M']='M';mp['N']=' ';
    mp['O']='O';mp['P']=' ';mp['Q']=' ';mp['R']=' ';mp['S']='2';mp['T']='T';mp['U']='U';
    mp['V']='V';mp['W']='W';mp['X']='X';mp['Y']='Y';mp['Z']='5';mp['1']='1';mp['2']='S';
    mp['3']='E';mp['4']=' ';mp['5']='Z';mp['6']=' ';mp['7']=' ';mp['8']='8';mp['9']=' ';
}

void solve(){
    int flag1=0,flag2=0;
    for(int i=0;i<=(str.length()+1)/2;i++){
        if(str[i]==str[str.length()-i-1]){
             flag1=1;
        }
        else if((str[i]=='O'||str[i]=='0')&&(str[str.length()-i-1]=='O'||str[str.length()-i-1]=='0'))
            flag1=1;
        else {
            flag1=0;
            break;
        }
    }
     for(int i=0;i<=(str.length()+1)/2;i++){
        if(mp[str[i]]==str[str.length()-i-1]){
                 flag2=1;
        }
        else if((str[i]=='O'||str[i]=='0')&&(str[str.length()-i-1]=='O'||str[str.length()-i-1]=='0'))
            flag2=1;
        else {
            flag2=0;
            break;
        }
    }
    if(flag1!=1&&flag2!=1)
        cout<<str<<" -- is not a palindrome."<<endl<<endl;
    if(flag1==1&&flag2!=1)
        cout<<str<<" -- is a regular palindrome."<<endl<<endl;
    if(flag2==1&&flag1!=1)
        cout<<str<<" -- is a mirrored string."<<endl<<endl;
    if(flag1==1&&flag2==1)
        cout<<str<<" -- is a mirrored palindrome."<<endl<<endl;
}

int main(){
    initial();
    while(cin>>str){
        solve();
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐